Moodle 3.4 or later requires at least PHP 7.0.0 (currently using version 5.6.32-1+ubuntu16.04.1+deb.sury.org+1). Some servers may have multiple PHP versions installed, are you using the correct executable?